Sparkfun BlueSmirf Gold
Tips for setting up with MITes receiver:

  1. Determine if you have the old or new module: The old has a white antenna, while the new one has a blue antenna. Their factory settings are as follows:
    BlueSmirf old version
    default baud rate: 9600,N,8,1
    pass key: "default"
    Enter to command mode: "+++"
    AT commands:http://rob.faludi.com/itp/BlueRadios_AT_Commands_Rev_2.8.1.4.0.pdf

    Bluesmirf new version
    default baud rate: 115k,N,8,1
    pass key: "1234"
    Enter to command mode: "$$$"
    AT commands:http://www.sparkfun.com/datasheets/RF/RN_BlueportII-ref-guide.pdf
  2. Make sure the BlueSmirf is discovered and connected. Check that com ports are assigned. (the communication with the bt module is via the outgoing com port).
  3. Using a terminal program (such as Hyperterminal for XP), make sure the Bluetooth module is communicating through the outgoing com port. It is known that Hyperterminal sometimes has some problems communicating with the Bluetooth serial port; If that's the case, be sure there are no problems with the Bluetooth stack (if possible use Bluesoleil) and that the baud rates match. If you still have problems with Hyperterminal, some alternatives are:
    Teraterm pro
    Advanced Serial Port Terminal
  4. To enter command mode: Check that the all pins are wired properly. The CTS/RTS pins should be linked, and the TX/RX pins should also be linked. See these pages for more info:
    http://www.lynxmotion.com/images/html/build125.htm
    http://forum.sparkfun.com/viewtopic.php?t=5399
    Type "$$$" or "+++" into the terminal (depending on your Bluesmirf version), and it should return an "OK".

Troubleshooting:
  • The MITes receiver is detected, but there is no data.
    • Check battery on MITes sensor
    • There is a known issue with receivers suddenly only sending DD headers. May be caused by random voltage spikes that cause chip malfunction.